Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» why do i get this error
Sun Apr 23, 2017 9:43 pm by anbarasi

» wait property
Sun Apr 23, 2017 12:50 pm by anbarasi

» What is the use of Selenium Remote Control
Fri Apr 21, 2017 7:24 pm by azharuddin

» How can I fix it? TCP PORT Exhaustion
Wed Apr 19, 2017 3:29 pm by JohnSnow

» Difference between QTP, Selenium and Silk test
Wed Apr 19, 2017 2:30 pm by Basilios Will

» Locator for google document
Tue Apr 18, 2017 10:01 pm by SergeyK

» I encountered a mistake: Couldn't register this node
Sat Apr 15, 2017 9:06 pm by skyshine725

» Current version tutorial for just creating a browser instance - Visual Studio
Fri Apr 14, 2017 2:47 am by KilpAr

» cant able to select drop down otions
Thu Apr 13, 2017 6:08 pm by anbarasi

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search

Trouble with iframe automation

View previous topic View next topic Go down

Trouble with iframe automation

Post by r2bhasin on Thu May 31, 2012 10:41 pm

Hi,
I'm currently automating webtrends call verification from any action within a widget(iframe). The different actions that trigger a webtrends call are -
clicking a content link inside the widget
clicking on the bookmark icon to the right of each headline within the widget
clicking on pagination links inside the widget
clicking on edit settings which loads the settings page inside the widget

I have managed to automate edit and saving the settings but for actions that need interacting with objects inside the iframes, it is throiwnig an error, following is the code that works -


storeEval
this.browserbot.getUserWindow()._tag.images.length
webtrendsImgCount



click
css=#gadget-pane-11207  a.settings:contains('Edit preferences')



pause
10000



clickAndWait
id=cancelButton




assertEval
this.browserbot.getUserWindow()._tag.images.length
javascript{storedVars['webtrendsImgCount']-(-1)}


Now this code works fine for editing settings but does not work for bookmarking, pagination etc.
this is the error that is thrown- [error] Threw an exception: this.browserbot.getUserWindow()._tag is undefined

Does anyone have any similar experience or can think of any solution??



r2bhasin

Posts : 2
Join date : 2012-05-31

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum