Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» FlexMonkium Download Not available under Gorillalogic site
Thu Dec 08, 2016 5:40 pm by bhanu.praveen

» Selenium Script issue
Tue Dec 06, 2016 9:48 pm by njain213

» Difference between QTP, Selenium and Silk test
Tue Dec 06, 2016 7:58 pm by jessicacyrus1

» Where does selenium script pick browser from
Tue Dec 06, 2016 1:52 pm by janbaskt

» Safari throws an HTTP ERROR: 404
Tue Dec 06, 2016 1:51 pm by janbaskt

» Access Denied Error in Selenium RC
Tue Dec 06, 2016 1:51 pm by janbaskt

» Automating Flex application through selenium webdriver
Fri Dec 02, 2016 2:06 pm by abhinay.krs

» Starting with Selenium, what is Selenium?
Mon Nov 28, 2016 4:00 pm by Foma

» Getting started with Selenium
Mon Nov 28, 2016 3:23 pm by Rebbelx

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search

Selenium RC server stuck at INFO - Checking Resource aliases

View previous topic View next topic Go down

Selenium RC server stuck at INFO - Checking Resource aliases

Post by mpetronic on Sun May 09, 2010 2:14 am

I'm brand new to Selenium. Trying to get a very simple test running just to start learning the tool. Using Windows 7 but I get the exact same problem on another PC running XP. I installed the Selenium IDE in FF 3.6 and I installed Selenium RC 1.0.1. I used the IDE to record a simple test that goes to news.google.com and does and clickandwait on three links that bring up "World", "U.S.", and "Business" pages. Real simple just to get started. I saved the HTML version of this test into c:/selenium_test/google_news.htm. This test runs fine in the IDE. Now I want to run the test via RC. Here's where the error occurs:

C:\selenium_1.0.1\selenium-server-1.0.3>java -jar selenium-server.jar -htmlSuite *firefox http://news.google.com c:\selenium_tests\google_news.htm c:\selenium_tests\google_news_results.htm
14:30:54.378 INFO - Java: Sun Microsystems Inc. 16.0-b13
14:30:54.378 INFO - OS: Windows 7 6.1 x86
14:30:54.393 INFO - v2.0 [a2], with Core v2.0 [a2]
14:30:54.471 INFO - RemoteWebDriver instances should connect to: http://127.0.0.1:4444/wd/hub
14:30:54.487 INFO - Version Jetty/5.1.x
14:30:54.487 INFO - Started HttpContext[/selenium-server/driver,/selenium-server/driver]
14:30:54.487 INFO - Started HttpContext[/selenium-server,/selenium-server]
14:30:54.487 INFO - Started HttpContext[/,/]
14:30:54.518 INFO - Started org.openqa.jetty.jetty.servlet.ServletHandler@14fe5c
14:30:54.518 INFO - Started HttpContext[/wd,/wd]
14:30:54.518 INFO - Started SocketListener on 0.0.0.0:4444
14:30:54.518 INFO - Started org.openqa.jetty.jetty.Server@110d81b
14:30:54.908 INFO - Preparing Firefox profile...
14:30:58.295 INFO - Launching Firefox...
14:31:01.198 INFO - Checking Resource aliases
14:31:33.537 INFO - Checking Resource aliases


It just hangs on Checking Resource aliases. Firefox does start up in two windows - one with the test runner panel and the other, I guess, is where the page will load. If I try to start the test by clicking the run button on the test panel, it does nothing. I did not install Selenium Core because I don't think I need to for my application of the tool. Basically, I want an automated testing setup that can drive FF, IE, Chrome, Safari through lots of public sites while the HTTP proxy-like application we develop sits in the middle doing what it does. We are sort of new to automated testing in our company and are already trying out technigues like Watir, JSystem, HTTPWatch automation API. To me, it seems like Selenium would be a good fit for an open source solution that we could use to develop customized tests. Guess I should of asked this question first, "Does this seem like a legitmate application of Selenium?" We are NOT trying to test a web application we build but rather a man-in-the-middle application and we want to test to ensure it does not break any existing sites.

Thanks in advance for any ideas...
Mark

mpetronic

Posts : 2
Join date : 2010-05-09

Back to top Go down

Re: Selenium RC server stuck at INFO - Checking Resource aliases

Post by kahulec on Mon May 10, 2010 8:23 pm

Hello
I had this problem when my Test file was not Suit. I saved Test file as Test Case not Test Suit. When i fixed it i have no problem anymore Smile
I hope that help you

kahulec

Posts : 1
Join date : 2010-05-10

Back to top Go down

Re: Selenium RC server stuck at INFO - Checking Resource aliases

Post by mpetronic on Mon May 10, 2010 11:55 pm

Thanks for the lead. I was able to run the test with FireFox and it worked. I had previously saved the test as a "Test Case" and that was NOT working. I saved it as a "Test Suite" and specified the test suite file name on the command like and that made it work.

mpetronic

Posts : 2
Join date : 2010-05-09

Back to top Go down

Re: Selenium RC server stuck at INFO - Checking Resource aliases

Post by Sponsored content Today at 7:15 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum