Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» FlexMonkium Download Not available under Gorillalogic site
Thu Dec 08, 2016 5:40 pm by bhanu.praveen

» Selenium Script issue
Tue Dec 06, 2016 9:48 pm by njain213

» Difference between QTP, Selenium and Silk test
Tue Dec 06, 2016 7:58 pm by jessicacyrus1

» Where does selenium script pick browser from
Tue Dec 06, 2016 1:52 pm by janbaskt

» Safari throws an HTTP ERROR: 404
Tue Dec 06, 2016 1:51 pm by janbaskt

» Access Denied Error in Selenium RC
Tue Dec 06, 2016 1:51 pm by janbaskt

» Automating Flex application through selenium webdriver
Fri Dec 02, 2016 2:06 pm by abhinay.krs

» Starting with Selenium, what is Selenium?
Mon Nov 28, 2016 4:00 pm by Foma

» Getting started with Selenium
Mon Nov 28, 2016 3:23 pm by Rebbelx

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search

Problem in File Upload executed through Jenkins Slave

View previous topic View next topic Go down

Problem in File Upload executed through Jenkins Slave

Post by zap86 on Thu May 08, 2014 1:07 pm

Hello,
I am trying to run the selenium testing through a Jenkins Slave connected by JNLP. Tests are performed in Internet Explorer using Selenium2 Webdriver.  
Master: Linux Server
Slave : Windows, Jenkins Slave is installed as a service with my login account (Not the local system account)
The issue is, testing hangs when it tries to do a file upload. If I manually login to the slave machine and execute the same test, It works perfectly fine. So I guess the issue is with the file upload browser window, which can not be picked up when the tests are run with JNLP. How can I fix this still using the Webdriver. Am I doing something wrong. Your suggestions are highly appreciated.
Thanks in advance,
Sampath

zap86

Posts : 2
Join date : 2014-05-08

Back to top Go down

Re: Problem in File Upload executed through Jenkins Slave

Post by zap86 on Thu May 08, 2014 2:28 pm

Hello,

I figured it out. The root cause was, I had been using Java Web Start Slave Agent (JNLP) as a Windows service. I disabled the service and directly connected slave to master with the provided jar. Then everything was working fine. Smile

This is just for others who may encounter the same issue.

Best Regards,
Sampath

zap86

Posts : 2
Join date : 2014-05-08

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum