Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» FlexMonkium Download Not available under Gorillalogic site
Thu Dec 08, 2016 5:40 pm by bhanu.praveen

» Selenium Script issue
Tue Dec 06, 2016 9:48 pm by njain213

» Difference between QTP, Selenium and Silk test
Tue Dec 06, 2016 7:58 pm by jessicacyrus1

» Where does selenium script pick browser from
Tue Dec 06, 2016 1:52 pm by janbaskt

» Safari throws an HTTP ERROR: 404
Tue Dec 06, 2016 1:51 pm by janbaskt

» Access Denied Error in Selenium RC
Tue Dec 06, 2016 1:51 pm by janbaskt

» Automating Flex application through selenium webdriver
Fri Dec 02, 2016 2:06 pm by abhinay.krs

» Starting with Selenium, what is Selenium?
Mon Nov 28, 2016 4:00 pm by Foma

» Getting started with Selenium
Mon Nov 28, 2016 3:23 pm by Rebbelx

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search

selenium-ant html formatting issue

View previous topic View next topic Go down

selenium-ant html formatting issue

Post by kevsbox on Wed Apr 22, 2015 10:27 pm

Hi

I am using Eclipse, Selenium and Ant.
I have a testing process which grabs screenshots and tries to display them in the end HTML.
The process which creates the html in the build.xml is fairly standard, see below.
Code:
    <target description="Create HTML report" name="junitreport" >
        <junitreport todir="${junit.output.dir}">
            <fileset dir="${junit.output.dir}">
                <include name="TEST-*.xml"/>
            </fileset>
            <report format="frames" todir="${junit.output.dir}"/>
        </junitreport>
    </target>
However the result html does not show the < and /> for the attachment lines. However if I manually fix this the images display correctly in any browser. Can anyone suggest how I can fix this please.

For example in the xml file we see
Code:
<img alt='Screenshot' src='../screenshots/Provider3.png'/>

and int the HTML file the same line is
& lt;img alt='Screenshot' src='../screenshots/Provider3.png'/& gt;
Note I have put a space after the &'s so they do not convert to < etc






Thanks

kevsbox

Posts : 4
Join date : 2015-04-22
Age : 46
Location : Here

Back to top Go down

Re: selenium-ant html formatting issue

Post by kevsbox on Thu Apr 23, 2015 9:53 pm

Dudes, sorted this by running a class after the html was created which replaced the offending text.
Smile

kevsbox

Posts : 4
Join date : 2015-04-22
Age : 46
Location : Here

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum