Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search

SmartGWT 2.4 user-extensions.js issues

View previous topic View next topic Go down

SmartGWT 2.4 user-extensions.js issues

Post by HDLP on Fri Jan 28, 2011 6:26 pm

Hi,

I'm new at Selenium IDE, and I'm trying to make it work with SmartGWT, but I'm facing an awkward issue with user-extensions that you eventually knows how to solve it.
Well, after deploying the user-extensions and the user-extensions-ide as mentioned at the manual I always obtain an error each time try to run a small test.

[error] Unexpected Exception: message ->
autWindow.isc.AutoTest.getPageCoords is not a function, fileName ->
chrome://selenium-ide/content/tools.js ->
file:///D:/Testing/Selenium/Selenium/user-extensions.js, lineNumber
-> 182, stack ->
("scLocator=//VLayout[ID="isc_OID_5"]/","")@chrome://selenium-ide/content/tools.js
-> file:///D:/Testing/Selenium/Selenium/user-extensions.js:182


Do you have any clue of what I'm doing wrong?
I'm using Selenium IDE 1.0.10* and the smartGWT 2.4 extensions.

Thanks in advance.
Henrique

HDLP

Posts : 5
Join date : 2011-01-28

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by Adviser on Fri Jan 28, 2011 7:13 pm

Hi,

First check that user extension doesn't contain any error.For this try to attach that extension in selenium ide and see whether selenium ide gives error when you restart IDE after attaching user extension.

Adviser
------------------------
------------------------

Posts : 379
Join date : 2009-07-30
Location : India

http://seleniumforum.forumotion.net

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by HDLP on Fri Jan 28, 2011 7:19 pm

Thanks for your promptly reply.
The user.extensions.js doesn't report any problem, they are the ones provided with the smartGWT 2.4 distribution. One of my main concerns is that I didn't find any reference to this error on the Internet, so probably I'm not doing things as I should.

The error is only reported after executing the test and it seems very weird that the function isn't recognized.

HDLP

Posts : 5
Join date : 2011-01-28

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by ckendrick on Tue Feb 01, 2011 2:08 am

You have a mismatch between your SmartGWT version and the version of your user-extensions.js file. Use the user-extensions.js file included with 2.4 instead.

ckendrick

Posts : 2
Join date : 2011-02-01

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by HDLP on Tue Feb 01, 2011 2:54 am

I'm using the user-extensions.js provided with the SmartGWT 2.4 version. I also have double check it, by downloading the smartgwt 2.4 file more than once.
Could you please provide me your user-extensions.js ?

Just to clarify I set the user-extensions.js at Sellenium Core extensions (user-extensions.js) and I'm accessing the web application from another computer, I mean, I don't have the smartgwt locally deployed in my computer.

HDLP

Posts : 5
Join date : 2011-01-28

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by ckendrick on Tue Feb 01, 2011 2:59 am

No really, there is a mismatch in version. It's an absolute certainty from the error you are reporting, because you are missing a function in AutoTest.js which exists in 2.4 but not prior releases.

Check all your versions carefully, clear caches, etc. You may also need to go a GWT Compile in case the staleness is in the IDE.

ckendrick

Posts : 2
Join date : 2011-02-01

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by HDLP on Tue Feb 01, 2011 7:28 pm

Thanks a lot, it's very frustrating when your team assures you that they are using version 2.4 and finally you discover it's 2.2

After replacing the files things started to work as expected.

HDLP

Posts : 5
Join date : 2011-01-28

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by nobel on Fri Mar 25, 2011 4:13 pm

Hi HDLP,
I am also trying to use Selenium Testing with SmartGWT. If you have succeeded Selenium Testing with SmartGWT, could you possibly share the smartGWT application with me?

nobel
Active particpant
Active particpant

Posts : 18
Join date : 2011-03-25
Age : 28

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by HDLP on Sun Mar 27, 2011 6:46 am

Hi Nobel,

You have to browse you smartGWT downloaded file to find the files:
-user-extensions.js
-user-extensions-ide.js

be sure you are using the same version you use to develop, my problem was that, my team was developing using smartgwt 2.2 and I was using smartgwt 2.4 to test..
After finding the files, just define them:

- user-extensions.js as Selenium core Extensions
-user-extensions-ide.js as Selenium IDE Extensions

Just let me know if it worked.

HDLP

Posts : 5
Join date : 2011-01-28

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by nobel on Thu Apr 07, 2011 12:49 pm

Hi HDLP,

I have a problem of running a Testcase of Junit(java) with the Selenium RC
Server.I am using Eclipse IDE. Selenium Documents says that we need
to run the selenium RC as follows:

java -jar selenium-server.jar -userExtensions user-extensions.js in the
command prompt.

From where do i have to take this "user-extensions.js" file?. Please clarify more about this User Extension. I have already read about User Extension from Selenium Documents.

I was taken a "user-extensions.js" file from smartgwt2.4/selenium/user-extension.js
and i run the file along with the selenium-server.jar in the command prompt. I got the following error as follows: [please help me to solve this issue, its emergency]

com.thoughtworks.selenium.SeleniumException:
ERROR: Element scLocator=//DynamicForm[ID="isc_DynamicForm_0"]/item[name=fName||title=Name||value=nobel||index=0||Class=TextItem]/element
not found at
com.thoughtworks.selenium.HttpCommandProcessor.doCommand(HttpCommandProcessor.java:73)
at

com.thoughtworks.selenium.DefaultSelenium.type(DefaultSelenium.java:178)
at

com.example.helloworld.client.HelloWorldTest.testHelloWorld(HelloWorldTest.java:19)
at
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at

sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at
java.lang.reflect.Method.invoke(Method.java:597)
at
junit.framework.TestCase.runTest(TestCase.java:168)
at
junit.framework.TestCase.runBare(TestCase.java:134)
at
com.thoughtworks.selenium.SeleneseTestCase.runBare(SeleneseTestCase.java:71)
at
junit.framework.TestResult$1.protect(TestResult.java:110)
at
junit.framework.TestResult.runProtected(TestResult.java:128)
at
junit.framework.TestResult.run(TestResult.java:113)
at
junit.framework.TestCase.run(TestCase.java:124)
at
junit.framework.TestSuite.runTest(TestSuite.java:232)
at
junit.framework.TestSuite.run(TestSuite.java:227)
at
org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:83)
at

org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:46)
at

org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
at

org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
at

org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
at

org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
at

org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)

nobel
Active particpant
Active particpant

Posts : 18
Join date : 2011-03-25
Age : 28

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by Swati Bhargava on Mon Jul 04, 2011 6:56 pm

Hi,
I am also trying to use Selenium Testing with SmartGWT.
I am using Smartgwt 2.4 and selenium version 1.0.10 and developed application in gwt1.7 version.

I always obtain an error each time try to run a small test.

[error] Unexpected Exception: message ->
autWindow.isc.AutoTest.getPageCoords is not a function, fileName ->
chrome://selenium-ide/content/tools.js ->
file:///D:/Testing/Selenium/Selenium/user-extensions.js, lineNumber
-> 182, stack ->
("scLocator=//VLayout[ID="isc_OID_5"]/","")@chrome://selenium-ide/content/tools.js
-> file:///D:/Testing/Selenium/Selenium/user-extensions.js:182


I am using the:

- user-extensions.js as Selenium core Extensions
-user-extensions-ide.js as Selenium IDE Extensions

Do you have any clue of what I'm doing wrong?


Thanks & Regards:
Swati Bhargava

Swati Bhargava

Posts : 1
Join date : 2011-07-04

Back to top Go down

Re: SmartGWT 2.4 user-extensions.js issues

Post by Sponsored content Today at 9:05 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum