Search
 
 

Display results as :
 


Rechercher Advanced Search

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search

Selenium IDE recognize elements Selenium RC not

View previous topic View next topic Go down

Selenium IDE recognize elements Selenium RC not

Post by Trust on Wed Mar 09, 2011 6:36 pm

Hi all,

This is my problem i was making some testsuites with Selenium IDE and all the tests runs fine launching it manually from Selenium IDE. In a second step i installed Selenium RC basically for crossbrowser testing and the same test suites are not running cause doesnt find elements in the webpage that Selenium IDE is finding. Someone note this behavior? or im doing something wrong?

Kind Regards,

Rafa

Trust

Posts : 5
Join date : 2011-03-09

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by thumatiraja on Fri Mar 11, 2011 2:09 pm

hi
i am not getting you clearly,
according to your's it not your problem.i think it's application problem.
can you clearly exaplain that.......

thumatiraja
Active particpant
Active particpant

Posts : 19
Join date : 2011-03-11
Age : 30
Location : Hyderabad

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by Trust on Fri Mar 11, 2011 5:02 pm

Sure,
I start making the tests with Selenium IDE and runnig it manually from IDE too and all the tests PASS i.e verifyElementPresent in some element in my webpage. But when i try to launch the same test from Selenium RC, this doesnt find or recognize the elements. Sure that isnt a load time problem cause the first test is a 30s pause to assure that all is loaded.

Trust

Posts : 5
Join date : 2011-03-09

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by thumatiraja on Fri Mar 11, 2011 5:14 pm

hi
i think there is click and wait problem is there
change it once......then you will get the correct solution........
............

did you get it???????

thumatiraja
Active particpant
Active particpant

Posts : 19
Join date : 2011-03-11
Age : 30
Location : Hyderabad

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by Trust on Fri Mar 11, 2011 6:51 pm

Do you mean that i have to put a clickandwait function before the verifyElementPresent?

Trust

Posts : 5
Join date : 2011-03-09

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by thumatiraja on Fri Mar 11, 2011 7:07 pm

Yes Exacyly..........


Thanks

thumatiraja
Active particpant
Active particpant

Posts : 19
Join date : 2011-03-11
Age : 30
Location : Hyderabad

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by Trust on Fri Mar 11, 2011 11:00 pm

No way, i dont understand this behavior. The only solutions is try to export all test cases to java i think... Sad

Trust

Posts : 5
Join date : 2011-03-09

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by gaurang033 on Thu Mar 24, 2011 1:45 pm

check out this.
http://qtp-help.blogspot.com/2009/09/selenium-element-not-found.html

gaurang033
Active particpant
Active particpant

Posts : 13
Join date : 2011-03-19

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by auto_ashish1 on Tue Apr 05, 2011 11:49 pm

There can be 2 errors

1) You have not used selenium.waitforPagetoLoad(timeout) function. You need to use it whenever new page loads.

2) The IDs of you elements are not correct. Try installing an add-on in mozila called 'xpather' . It can help you get the correct xpaths and IDs

Regards
Ashish
itsthakur@gmail.com
91-9888179981

For online Selenium training go to my website- www.sejsoft.com

auto_ashish1
Active particpant
Active particpant

Posts : 21
Join date : 2011-03-10

Back to top Go down

Re: Selenium IDE recognize elements Selenium RC not

Post by Sponsored content Today at 7:11 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum