Display results as :

Rechercher Advanced Search

Latest topics

Exported Selenium Script Throws Exception

View previous topic View next topic Go down

Exported Selenium Script Throws Exception

Post by flower07 on Fri Sep 02, 2011 5:00 pm

I recorded an action using the Selenium IDE and used the File->Export Test Cases as Python 2 (Remote Control) format.

I am using Selenium RC 2.3.0

I then ran the script from command prompt but it throws an exception.

The exported Python 2 RC code is:

from selenium import selenium
import unittest, time, re

class login(unittest.TestCase):
  def setUp(self):
      self.verificationErrors = []
      self.selenium = selenium("localhost", 4444, "*chrome", "http://

  def test_login(self):
      sel = self.selenium"/WebAccess/login.html")
      sel.type("id=LoginID", "Administrator")
      sel.type("id=Password", "Administrator")"id=login")
      sel.wait_for_page_to_load("30000")"link=Home") # This is where it fails.

  def tearDown(self):
      self.assertEqual([], self.verificationErrors)

if __name__ == "__main__":

At this line -"link=Home") it fails with the exception

ERROR: test_login (__main__.login)
Traceback (most recent call last):
 File "C:\Documents and Settings\User\Desktop\", line 16, in
 File "C:\Python27\lib\selenium\", line 290, in click
  self.do_command("click", [locator,])
 File "C:\Python27\lib\selenium\", line 217, in do_command
  raise Exception, data
Exception: ERROR: Element link=Home not found


I even tried increasing the 30000 to 60000 but still no help. I can see
the page is loaded fully and waiting for a while because of the higher
timeout. However when executing this link=Home it fails.

The HTML code is:

<div class="links nopreview">
<span><a class="csiAction" href="/WebAccess/home.html#URL=centric://
<span> • </span>
<span><span><a class="csiAction" href="/WebAccess/
</span><span> • </span>
</span><span><a title="Sign Out" class="csiAction csiActionLink">Sign
The recorded actions using IDE are:



I did run the test using IDE's recorded script. It works great. I was
able to login and click on the Home link too. However, it fails with
that exception when I wanted to run it using Python's Unittest with
Selenium Server 2.3.0.

I tried'//a[contains(text((),"Home")]') and it throws the exception

Traceback (most recent call last): File "C:\Documents and
Settings\User\Desktop\", line 17, in test_log in'//a[contains(text((),"Home")]') File
"C:\Python27\lib\selenium\", line 290, in click
self.do_command("click", [locator,])
File "C:\Python27\lib\selenium\", line 217, in do_command raise Exception, data Exception:
ERROR: Invalid xpath [2]: //a[contains(text((),"Home")]

I even tried'xpath=//a[contains(text((),"Home")]') and it
still throws the same exception as mentioned in the above comment. I
wonder what could be wrong. If I comment the line that clicks on the
Home link then it runs fine. Its the problem with clicking this link.

To add, not only for Home. It does not work for Home or Setup or even
Signout for that matter. It does not work for any of the links in that
div. However playing back the recorded script works fine!

Any suggestions or guidance, please?


Posts : 3
Join date : 2011-08-05

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

Permissions in this forum:
You cannot reply to topics in this forum