Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» how to connect DB in selenium webriver
Fri Oct 06, 2017 4:09 pm by anbarasi

» How find any text in browser screen and click on it?
Thu Oct 05, 2017 2:02 pm by sandeepkommineni

» Selenium Webdriver
Tue Oct 03, 2017 1:35 pm by PiyushBiswas

» GRID setup tutorial.
Wed Sep 27, 2017 4:29 pm by johnyapp

» Drag & Drop Between Windows Using Selenium Driver
Wed Sep 27, 2017 2:10 pm by 26rondel

» Check if window is closed / verify input
Sat Sep 23, 2017 10:21 pm by brainstir

» How to work on pages with AJAX in selenium?
Mon Sep 18, 2017 6:08 pm by azharuddin

» pause test until user press a key like F2
Wed Aug 09, 2017 11:10 pm by djnforce

» Selecting the input for auto populating element
Sat Jul 29, 2017 7:53 pm by kdabbara

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search

Weird behavior by IE driver when entering value in password field

View previous topic View next topic Go down

Weird behavior by IE driver when entering value in password field

Post by Prateek_12 on Mon Aug 15, 2011 8:51 pm

HI

I have written a small sample to log on to my application using Webdriver 2 and then checking the page title.
The problem is in the password element the code is entering the password mentioned thrice or sometime four times as a result successfull login is not happenning. The user name is getting entered correctly but its password which is giving problem. Its really strange since the code is same for both the fields . Following is the code

driver = new InternetExplorerDriver();
driver.Manage().Timeouts().ImplicitlyWait(new TimeSpan(0,0,30));
driver.Navigate().GoToUrl("xyz.com");

IWebElement password = driver.FindElement(By.Id("txtPassword"));
password.SendKeys("password2"); \\ Instead the code is entering "password2password2password2"
Thread.Sleep(100);
IWebElement username = driver.FindElement(By.Id("txtLoginName"));
username.SendKeys("cwwsadmin"); \\ This value is getting entered correctly
IWebElement signin = driver.FindElement(By.Id("btnLogin"));
signin.Submit();
driver.Close();

Please let me know where i am making the mistake


Prateek_12

Posts : 4
Join date : 2011-07-19

Back to top Go down

Re: Weird behavior by IE driver when entering value in password field

Post by Prateek_12 on Thu Aug 18, 2011 1:39 am

The Problem is solved, I was entering the value in the password field in the Test Initialize , when i moved this action to Test method it worked fine. Kind of strange , I am not able to get the reason behind it but the for the time being my problem is solved Very Happy

Prateek_12

Posts : 4
Join date : 2011-07-19

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum